Wednesday, 17 March 2021

How to play DVD disc on Ubuntu

Here is what I needed to do on my PC in order to play a DVD disc. 

I am running the Ubuntu 20.04:

$ sudo lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal


I chose to use VLC media player.


VLC installation:

$ sudo apt install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  liba52-0.7.4 libaribb24-0 libbasicusageenvironment1 libcddb2 libdca0 libdvbpsi10 libdvdnav4 libdvdread7 libebml4v5 libfaad2 libgroupsock8 libixml10 libkate1 liblivemedia77 libmad0
  libmatroska6v5 libmpcdec6 libmpeg2-4 libopenmpt-modplug1 libplacebo7 libproxy-tools libresid-builder0c2a libsdl-image1.2 libsidplay2 libspatialaudio0 libsrt1 libssh2-1 libupnp13
  libusageenvironment3 libva-wayland2 libvlc-bin libvlc5 libvlccore9 vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2
  vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
Suggested packages:
  libdvdcss2
The following NEW packages will be installed
  liba52-0.7.4 libaribb24-0 libbasicusageenvironment1 libcddb2 libdca0 libdvbpsi10 libdvdnav4 libdvdread7 libebml4v5 libfaad2 libgroupsock8 libixml10 libkate1 liblivemedia77 libmad0
  libmatroska6v5 libmpcdec6 libmpeg2-4 libopenmpt-modplug1 libplacebo7 libproxy-tools libresid-builder0c2a libsdl-image1.2 libsidplay2 libspatialaudio0 libsrt1 libssh2-1 libupnp13
  libusageenvironment3 libva-wayland2 libvlc-bin libvlc5 libvlccore9 vlc vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2
  vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
0 to upgrade, 45 to newly install, 0 to remove and 18 not to upgrade.
Need to get 13.7 MB of archives.
After this operation, 71.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 liba52-0.7.4 amd64 0.7.4-20 [30.5 kB]
Get:2 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libaribb24-0 amd64 1.0.3-2 [26.9 kB]
Get:3 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libusageenvironment3 amd64 2020.01.19-1build1 [6,960 B]
Get:4 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libbasicusageenvironment1 amd64 2020.01.19-1build1 [15.2 kB]
Get:5 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libcddb2 amd64 1.3.2-6fakesync1 [34.3 kB]
Get:6 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libdvbpsi10 amd64 1.3.3-1 [47.1 kB]
Get:7 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libdvdread7 amd64 6.1.0+really6.0.2-1 [49.9 kB]
Get:8 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libdvdnav4 amd64 6.0.1-1build1 [39.0 kB]
Get:9 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libebml4v5 amd64 1.3.10-1build1 [49.1 kB]
Get:10 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libfaad2 amd64 2.9.1-1 [154 kB]
Get:11 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libgroupsock8 amd64 2020.01.19-1build1 [20.7 kB]
Get:12 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libixml10 amd64 1:1.8.4-2ubuntu2 [23.6 kB]
Get:13 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libkate1 amd64 0.4.1-11build1 [39.4 kB]
Get:14 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 liblivemedia77 amd64 2020.01.19-1build1 [318 kB]
Get:15 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libmad0 amd64 0.15.1b-10ubuntu1 [63.1 kB]
Get:16 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libmatroska6v5 amd64 1.5.2-3build1 [124 kB]
Get:17 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libmpcdec6 amd64 2:0.1~r495-2 [32.4 kB]
Get:18 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libmpeg2-4 amd64 0.5.1-9 [50.7 kB]
Get:19 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libopenmpt-modplug1 amd64 0.4.11-1build1 [20.0 kB]
Get:20 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libplacebo7 amd64 1.7.0-2 [721 kB]
Get:21 http://gb.archive.ubuntu.com/ubuntu focal-updates/universe amd64 libproxy-tools amd64 0.4.15-10ubuntu1.2 [5,440 B]
Get:22 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libresid-builder0c2a amd64 2.1.1-15ubuntu2 [31.3 kB]
Get:23 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libsdl-image1.2 amd64 1.2.12-12 [30.0 kB]
Get:24 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libsidplay2 amd64 2.1.1-15ubuntu2 [89.2 kB]
Get:25 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libspatialaudio0 amd64 0.3.0+git20180730+dfsg1-2build1 [32.9 kB]
Get:26 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libsrt1 amd64 1.4.0-1build1 [236 kB]
Get:27 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libssh2-1 amd64 1.8.0-2.1build1 [75.4 kB]
Get:28 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libupnp13 amd64 1:1.8.4-2ubuntu2 [87.9 kB]
Get:29 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libva-wayland2 amd64 2.7.0-2 [8,924 B]
Get:30 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libvlccore9 amd64 3.0.9.2-1 [428 kB]
Get:31 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libvlc5 amd64 3.0.9.2-1 [65.8 kB]
Get:32 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libvlc-bin amd64 3.0.9.2-1 [17.1 kB]
Get:33 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-bin amd64 3.0.9.2-1 [54.2 kB]
Get:34 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-data all 3.0.9.2-1 [339 kB]
Get:35 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 libdca0 amd64 0.0.6-1 [91.0 kB]
Get:36 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-plugin-base amd64 3.0.9.2-1 [2,854 kB]
Get:37 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-plugin-qt amd64 3.0.9.2-1 [1,054 kB]
Get:38 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-plugin-video-output amd64 3.0.9.2-1 [160 kB]
Get:39 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc amd64 3.0.9.2-1 [34.0 kB]
Get:40 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-l10n all 3.0.9.2-1 [5,584 kB]
Get:41 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-plugin-notify amd64 3.0.9.2-1 [18.2 kB]
Get:42 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-plugin-samba amd64 3.0.9.2-1 [18.8 kB]
Get:43 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-plugin-skins2 amd64 3.0.9.2-1 [471 kB]
Get:44 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-plugin-video-splitter amd64 3.0.9.2-1 [32.4 kB]
Get:45 http://gb.archive.ubuntu.com/ubuntu focal/universe amd64 vlc-plugin-visualization amd64 3.0.9.2-1 [36.2 kB]
Fetched 13.7 MB in 4s (3,493 kB/s)                    
Extract templates from packages: 100%
Selecting previously unselected package liba52-0.7.4:amd64.
(Reading database ... 350491 files and directories currently installed.)
Preparing to unpack .../00-liba52-0.7.4_0.7.4-20_amd64.deb ...
Unpacking liba52-0.7.4:amd64 (0.7.4-20) ...
Selecting previously unselected package libaribb24-0:amd64.
Preparing to unpack .../01-libaribb24-0_1.0.3-2_amd64.deb ...
Unpacking libaribb24-0:amd64 (1.0.3-2) ...
Selecting previously unselected package libusageenvironment3:amd64.
Preparing to unpack .../02-libusageenvironment3_2020.01.19-1build1_amd64.deb ...
Unpacking libusageenvironment3:amd64 (2020.01.19-1build1) ...
Selecting previously unselected package libbasicusageenvironment1:amd64.
Preparing to unpack .../03-libbasicusageenvironment1_2020.01.19-1build1_amd64.deb ...
Unpacking libbasicusageenvironment1:amd64 (2020.01.19-1build1) ...
Selecting previously unselected package libcddb2.
Preparing to unpack .../04-libcddb2_1.3.2-6fakesync1_amd64.deb ...
Unpacking libcddb2 (1.3.2-6fakesync1) ...
Selecting previously unselected package libdvbpsi10:amd64.
Preparing to unpack .../05-libdvbpsi10_1.3.3-1_amd64.deb ...
Unpacking libdvbpsi10:amd64 (1.3.3-1) ...
Selecting previously unselected package libdvdread7:amd64.
Preparing to unpack .../06-libdvdread7_6.1.0+really6.0.2-1_amd64.deb ...
Unpacking libdvdread7:amd64 (6.1.0+really6.0.2-1) ...
Selecting previously unselected package libdvdnav4:amd64.
Preparing to unpack .../07-libdvdnav4_6.0.1-1build1_amd64.deb ...
Unpacking libdvdnav4:amd64 (6.0.1-1build1) ...
Selecting previously unselected package libebml4v5:amd64.
Preparing to unpack .../08-libebml4v5_1.3.10-1build1_amd64.deb ...
Unpacking libebml4v5:amd64 (1.3.10-1build1) ...
Selecting previously unselected package libfaad2:amd64.
Preparing to unpack .../09-libfaad2_2.9.1-1_amd64.deb ...
Unpacking libfaad2:amd64 (2.9.1-1) ...
Selecting previously unselected package libgroupsock8:amd64.
Preparing to unpack .../10-libgroupsock8_2020.01.19-1build1_amd64.deb ...
Unpacking libgroupsock8:amd64 (2020.01.19-1build1) ...
Selecting previously unselected package libixml10:amd64.
Preparing to unpack .../11-libixml10_1%3a1.8.4-2ubuntu2_amd64.deb ...
Unpacking libixml10:amd64 (1:1.8.4-2ubuntu2) ...
Selecting previously unselected package libkate1:amd64.
Preparing to unpack .../12-libkate1_0.4.1-11build1_amd64.deb ...
Unpacking libkate1:amd64 (0.4.1-11build1) ...
Selecting previously unselected package liblivemedia77:amd64.
Preparing to unpack .../13-liblivemedia77_2020.01.19-1build1_amd64.deb ...
Unpacking liblivemedia77:amd64 (2020.01.19-1build1) ...
Selecting previously unselected package libmad0:amd64.
Preparing to unpack .../14-libmad0_0.15.1b-10ubuntu1_amd64.deb ...
Unpacking libmad0:amd64 (0.15.1b-10ubuntu1) ...
Selecting previously unselected package libmatroska6v5:amd64.
Preparing to unpack .../15-libmatroska6v5_1.5.2-3build1_amd64.deb ...
Unpacking libmatroska6v5:amd64 (1.5.2-3build1) ...
Selecting previously unselected package libmpcdec6:amd64.
Preparing to unpack .../16-libmpcdec6_2%3a0.1~r495-2_amd64.deb ...
Unpacking libmpcdec6:amd64 (2:0.1~r495-2) ...
Selecting previously unselected package libmpeg2-4:amd64.
Preparing to unpack .../17-libmpeg2-4_0.5.1-9_amd64.deb ...
Unpacking libmpeg2-4:amd64 (0.5.1-9) ...
Selecting previously unselected package libopenmpt-modplug1:amd64.
Preparing to unpack .../18-libopenmpt-modplug1_0.4.11-1build1_amd64.deb ...
Unpacking libopenmpt-modplug1:amd64 (0.4.11-1build1) ...
Selecting previously unselected package libplacebo7:amd64.
Preparing to unpack .../19-libplacebo7_1.7.0-2_amd64.deb ...
Unpacking libplacebo7:amd64 (1.7.0-2) ...
Selecting previously unselected package libproxy-tools.
Preparing to unpack .../20-libproxy-tools_0.4.15-10ubuntu1.2_amd64.deb ...
Unpacking libproxy-tools (0.4.15-10ubuntu1.2) ...
Selecting previously unselected package libresid-builder0c2a.
Preparing to unpack .../21-libresid-builder0c2a_2.1.1-15ubuntu2_amd64.deb ...
Unpacking libresid-builder0c2a (2.1.1-15ubuntu2) ...
Selecting previously unselected package libsdl-image1.2:amd64.
Preparing to unpack .../22-libsdl-image1.2_1.2.12-12_amd64.deb ...
Unpacking libsdl-image1.2:amd64 (1.2.12-12) ...
Selecting previously unselected package libsidplay2.
Preparing to unpack .../23-libsidplay2_2.1.1-15ubuntu2_amd64.deb ...
Unpacking libsidplay2 (2.1.1-15ubuntu2) ...
Selecting previously unselected package libspatialaudio0:amd64.
Preparing to unpack .../24-libspatialaudio0_0.3.0+git20180730+dfsg1-2build1_amd64.deb ...
Unpacking libspatialaudio0:amd64 (0.3.0+git20180730+dfsg1-2build1) ...
Selecting previously unselected package libsrt1:amd64.
Preparing to unpack .../25-libsrt1_1.4.0-1build1_amd64.deb ...
Unpacking libsrt1:amd64 (1.4.0-1build1) ...
Selecting previously unselected package libssh2-1:amd64.
Preparing to unpack .../26-libssh2-1_1.8.0-2.1build1_amd64.deb ...
Unpacking libssh2-1:amd64 (1.8.0-2.1build1) ...
Selecting previously unselected package libupnp13:amd64.
Preparing to unpack .../27-libupnp13_1%3a1.8.4-2ubuntu2_amd64.deb ...
Unpacking libupnp13:amd64 (1:1.8.4-2ubuntu2) ...
Selecting previously unselected package libva-wayland2:amd64.
Preparing to unpack .../28-libva-wayland2_2.7.0-2_amd64.deb ...
Unpacking libva-wayland2:amd64 (2.7.0-2) ...
Selecting previously unselected package libvlccore9:amd64.
Preparing to unpack .../29-libvlccore9_3.0.9.2-1_amd64.deb ...
Unpacking libvlccore9:amd64 (3.0.9.2-1) ...
Selecting previously unselected package libvlc5:amd64.
Preparing to unpack .../30-libvlc5_3.0.9.2-1_amd64.deb ...
Unpacking libvlc5:amd64 (3.0.9.2-1) ...
Selecting previously unselected package libvlc-bin:amd64.
Preparing to unpack .../31-libvlc-bin_3.0.9.2-1_amd64.deb ...
Unpacking libvlc-bin:amd64 (3.0.9.2-1) ...
Selecting previously unselected package vlc-bin.
Preparing to unpack .../32-vlc-bin_3.0.9.2-1_amd64.deb ...
Unpacking vlc-bin (3.0.9.2-1) ...
Selecting previously unselected package vlc-data.
Preparing to unpack .../33-vlc-data_3.0.9.2-1_all.deb ...
Unpacking vlc-data (3.0.9.2-1) ...
Selecting previously unselected package libdca0:amd64.
Preparing to unpack .../34-libdca0_0.0.6-1_amd64.deb ...
Unpacking libdca0:amd64 (0.0.6-1) ...
Selecting previously unselected package vlc-plugin-base:amd64.
Preparing to unpack .../35-vlc-plugin-base_3.0.9.2-1_amd64.deb ...
Unpacking vlc-plugin-base:amd64 (3.0.9.2-1) ...
Selecting previously unselected package vlc-plugin-qt:amd64.
Preparing to unpack .../36-vlc-plugin-qt_3.0.9.2-1_amd64.deb ...
Unpacking vlc-plugin-qt:amd64 (3.0.9.2-1) ...
Selecting previously unselected package vlc-plugin-video-output:amd64.
Preparing to unpack .../37-vlc-plugin-video-output_3.0.9.2-1_amd64.deb ...
Unpacking vlc-plugin-video-output:amd64 (3.0.9.2-1) ...
Selecting previously unselected package vlc.
Preparing to unpack .../38-vlc_3.0.9.2-1_amd64.deb ...
Unpacking vlc (3.0.9.2-1) ...
Selecting previously unselected package vlc-l10n.
Preparing to unpack .../39-vlc-l10n_3.0.9.2-1_all.deb ...
Unpacking vlc-l10n (3.0.9.2-1) ...
Selecting previously unselected package vlc-plugin-notify:amd64.
Preparing to unpack .../40-vlc-plugin-notify_3.0.9.2-1_amd64.deb ...
Unpacking vlc-plugin-notify:amd64 (3.0.9.2-1) ...
Selecting previously unselected package vlc-plugin-samba:amd64.
Preparing to unpack .../41-vlc-plugin-samba_3.0.9.2-1_amd64.deb ...
Unpacking vlc-plugin-samba:amd64 (3.0.9.2-1) ...
Selecting previously unselected package vlc-plugin-skins2:amd64.
Preparing to unpack .../42-vlc-plugin-skins2_3.0.9.2-1_amd64.deb ...
Unpacking vlc-plugin-skins2:amd64 (3.0.9.2-1) ...
Selecting previously unselected package vlc-plugin-video-splitter:amd64.
Preparing to unpack .../43-vlc-plugin-video-splitter_3.0.9.2-1_amd64.deb ...
Unpacking vlc-plugin-video-splitter:amd64 (3.0.9.2-1) ...
Selecting previously unselected package vlc-plugin-visualization:amd64.
Preparing to unpack .../44-vlc-plugin-visualization_3.0.9.2-1_amd64.deb ...
Unpacking vlc-plugin-visualization:amd64 (3.0.9.2-1) ...
Setting up libsdl-image1.2:amd64 (1.2.12-12) ...
Setting up libkate1:amd64 (0.4.1-11build1) ...
Setting up libdvbpsi10:amd64 (1.3.3-1) ...
Setting up libebml4v5:amd64 (1.3.10-1build1) ...
Setting up libdvdread7:amd64 (6.1.0+really6.0.2-1) ...
Setting up libspatialaudio0:amd64 (0.3.0+git20180730+dfsg1-2build1) ...
Setting up vlc-l10n (3.0.9.2-1) ...
Setting up libmpeg2-4:amd64 (0.5.1-9) ...
Setting up libaribb24-0:amd64 (1.0.3-2) ...
Setting up libusageenvironment3:amd64 (2020.01.19-1build1) ...
Setting up libmpcdec6:amd64 (2:0.1~r495-2) ...
Setting up libcddb2 (1.3.2-6fakesync1) ...
Setting up liba52-0.7.4:amd64 (0.7.4-20) ...
Setting up libmatroska6v5:amd64 (1.5.2-3build1) ...
Setting up libixml10:amd64 (1:1.8.4-2ubuntu2) ...
Setting up libresid-builder0c2a (2.1.1-15ubuntu2) ...
Setting up libfaad2:amd64 (2.9.1-1) ...
Setting up libbasicusageenvironment1:amd64 (2020.01.19-1build1) ...
Setting up libvlccore9:amd64 (3.0.9.2-1) ...
Setting up libsidplay2 (2.1.1-15ubuntu2) ...
Setting up libva-wayland2:amd64 (2.7.0-2) ...
Setting up libmad0:amd64 (0.15.1b-10ubuntu1) ...
Setting up libsrt1:amd64 (1.4.0-1build1) ...
Setting up vlc-plugin-qt:amd64 (3.0.9.2-1) ...
Setting up libdca0:amd64 (0.0.6-1) ...
Setting up libssh2-1:amd64 (1.8.0-2.1build1) ...
Setting up libopenmpt-modplug1:amd64 (0.4.11-1build1) ...
Setting up vlc-data (3.0.9.2-1) ...
Setting up libplacebo7:amd64 (1.7.0-2) ...
Setting up vlc-plugin-notify:amd64 (3.0.9.2-1) ...
Setting up libdvdnav4:amd64 (6.0.1-1build1) ...
Setting up libproxy-tools (0.4.15-10ubuntu1.2) ...
Setting up vlc-plugin-video-output:amd64 (3.0.9.2-1) ...
Setting up vlc-plugin-samba:amd64 (3.0.9.2-1) ...
Setting up libgroupsock8:amd64 (2020.01.19-1build1) ...
Setting up vlc-plugin-skins2:amd64 (3.0.9.2-1) ...
Setting up vlc-plugin-video-splitter:amd64 (3.0.9.2-1) ...
Setting up libvlc5:amd64 (3.0.9.2-1) ...
Setting up libupnp13:amd64 (1:1.8.4-2ubuntu2) ...
Setting up vlc-plugin-visualization:amd64 (3.0.9.2-1) ...
Setting up libvlc-bin:amd64 (3.0.9.2-1) ...
Setting up liblivemedia77:amd64 (2020.01.19-1build1) ...
Setting up vlc-bin (3.0.9.2-1) ...
Setting up vlc-plugin-base:amd64 (3.0.9.2-1) ...
Setting up vlc (3.0.9.2-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
/sbin/ldconfig.real: /usr/local/cuda-8.0/targets/x86_64-linux/lib/libcudnn.so.5 is not a symbolic link

Processing triggers for man-db (2.9.1-1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for libvlc-bin:amd64 (3.0.9.2-1) ...


It was necessary to install several packages. 
 
libdvd-pkg package provides libraries that are needed for playing video DVDs with a media player (such as VLC, SMplayer, Totem, etc.). 
 
libdvdnav4 is a DVD navigation library, which provides an interface to the advanced features of DVDs, like menus and navigation. It contains the VM and other parts useful for writing DVD players.
 
libdvdread7 is a package for reading DVDs.

$ sudo apt install libdvd-pkg libdvdnav4 libdvdread7 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libdvdnav4 is already the newest version (6.0.1-1build1).
libdvdnav4 set to manually installed.
libdvdread7 is already the newest version (6.1.0+really6.0.2-1).
libdvdread7 set to manually installed.
The following NEW packages will be installed
  libdvd-pkg
0 to upgrade, 1 to newly install, 0 to remove and 18 not to upgrade.
Need to get 14.9 kB of archives.
After this operation, 80.9 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://gb.archive.ubuntu.com/ubuntu focal/multiverse amd64 libdvd-pkg all 1.4.2-1-1 [14.9 kB]
Fetched 14.9 kB in 0s (212 kB/s)    
Preconfiguring packages ...
Selecting previously unselected package libdvd-pkg.
(Reading database ... 351510 files and directories currently installed.)
Preparing to unpack .../libdvd-pkg_1.4.2-1-1_all.deb ...
Unpacking libdvd-pkg (1.4.2-1-1) ...
Setting up libdvd-pkg (1.4.2-1-1) ...
libdvd-pkg: dpkg database is locked. You may need to use command "sudo dpkg-reco
nfigure libdvd-pkg".
libdvd-pkg: Building and installation of package(s) [libdvdcss2 libdvdcss-dev] p
ostponed till after next APT operation.





$ sudo dpkg-reconfigure libdvd-pkg
libdvd-pkg: Downloading orig source...
I: libdvdcss_1.4.2
/usr/bin/wget --tries=3 --timeout=40 --read-timeout=40 --continue -O libdvdcss_1.4.2.orig.tar.bz2 \
          http://download.videolan.org/pub/libdvdcss/1.4.2/libdvdcss-1.4.2.tar.bz2 \
        || /usr/bin/uscan --noconf --verbose --rename --destdir=/usr/src/libdvd-pkg --check-dirname-level=0 --force-download --download-current-version /usr/share/libdvd-pkg/debian
--2021-03-17 08:02:21--  http://download.videolan.org/pub/libdvdcss/1.4.2/libdvdcss-1.4.2.tar.bz2
Resolving download.videolan.org (download.videolan.org)... 2a01:e0d:1:3:58bf:fa02:c0de:5, 213.36.253.2
Connecting to download.videolan.org (download.videolan.org)|2a01:e0d:1:3:58bf:fa02:c0de:5|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 366824 (358K) [application/octet-stream]
Saving to: ‘libdvdcss_1.4.2.orig.tar.bz2’

libdvdcss_1.4.2.orig.tar 100%[=================================>] 358.23K  2.27MB/s    in 0.2s    

2021-03-17 08:02:22 (2.27 MB/s) - ‘libdvdcss_1.4.2.orig.tar.bz2’ saved [366824/366824]

libdvd-pkg: Checking orig.tar integrity...
/usr/src/libdvd-pkg/libdvdcss_1.4.2.orig.tar.bz2: OK
libdvd-pkg: Unpacking and configuring...
libdvd-pkg: Building the package... (it may take a while)
libdvd-pkg: Build log will be saved to /usr/src/libdvd-pkg/libdvdcss2_1.4.2-1~local_amd64.build
Current: =ep
Bounding set =cap_chown,cap_dac_override,cap_fowner,cap_wake_alarm,cap_block_suspend,cap_audit_read
Ambient set =
Securebits: 024/0x14/5'b10100
 secure-noroot: no (unlocked)
 secure-no-suid-fixup: yes (unlocked)
 secure-keep-caps: yes (unlocked)
 secure-no-ambient-raise: no (unlocked)
uid=0(root) euid=0(root)
gid=0(root)
groups=0(root)
Guessed mode: UNCERTAIN (0)
libdvd-pkg: Installing...
Selecting previously unselected package libdvdcss-dev:amd64.
(Reading database ... 351541 files and directories currently installed.)
Preparing to unpack .../libdvdcss-dev_1.4.2-1~local_amd64.deb ...
Unpacking libdvdcss-dev:amd64 (1.4.2-1~local) ...
Selecting previously unselected package libdvdcss2:amd64.
Preparing to unpack .../libdvdcss2_1.4.2-1~local_amd64.deb ...
Unpacking libdvdcss2:amd64 (1.4.2-1~local) ...
Setting up libdvdcss2:amd64 (1.4.2-1~local) ...
Setting up libdvdcss-dev:amd64 (1.4.2-1~local) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
/sbin/ldconfig.real: /usr/local/cuda-8.0/targets/x86_64-linux/lib/libcudnn.so.5 is not a symbolic link


Upon installing dependencies, I was able to open and play DVD disc:






References:




1 comment:

micheal pan said...

BE SMART AND BECOME RICH IN LESS THAN 3DAYS....It all depends on how fast 
you can be to get the new PROGRAMMED blank ATM card that is capable of
hacking into any ATM machine,anywhere in the world. I got to know about 
this BLANK ATM CARD when I was searching for job online about a month 
ago..It has really changed my life for good and now I can say I'm rich and 
I can never be poor again. The least money I get in a day with it is about 
$50,000.(fifty thousand USD) Every now and then I keeping pumping money 
into my account. Though is illegal,there is no risk of being caught 
,because it has been programmed in such a way that it is not traceable,it 
also has a technique that makes it impossible for the CCTVs to detect 
you..For details on how to get yours today, email the hackers on : (
atmmachinehackers1@gmail.com ). Tell your 
loved once too, and start to live large. That's the simple testimony of how 
my life changed for good...Love you all ...the email address again is ;
atmmachinehackers1@gmail.com